You're here » Home Page » Forum » Re: No video stream incorect port number reported in debug [Help]

Connexion

Username:

Password:

Remember me



Lost Password?

Register now!

Social Networks


New Users

YGILouis66 2019/7/18
misty2211 2019/7/18
Juni73 2019/7/18
kadajpl 2019/7/16
trivox360 2019/7/16
BookerCars 2019/7/16
RhondaDeLo 2019/7/15
Lafe 2019/7/15
blondie157 2019/7/15
Maquedas 2019/7/15


Browsing this Thread:   1 Anonymous Users






Re: No video stream incorect port number reported in debug
#5
Débutant


Benutzerinformationen
I found out this is a client bug in the plugin on the satellite receiver.

I have filed a bug report here:
http://sbnc.dyndns.tv/trac/ticket/537


Posted on: 2017/9/6 14:16
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: No video stream incorect port number reported in debug
#4
Débutant


Benutzerinformationen
There are two web servers running their config is below:

# e2 web port
port=8080
# e2 data port
dataPort=8001
# titan web port
titanPort=80
# titan data port
titanDataPort=22222


but for some silly reason enigma tv does not use port 8001 as the stream port it uses 22222.
I don't know if this is a server or client bug.
I have tried alternative ports but it still picks up titannit stream port instead of the e2 stream port

I'm guessing all streaming should be done on port 8001 but for some reason 22222 is being used instead.

how does the receiver announce what port the stream port is and is there a way to specify the port to force the streaming from in enigma tv


Posted on: 2017/9/6 13:17
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: No video stream incorect port number reported in debug
#3
Accro


Benutzerinformationen
try changing the port, surely the port you are using are occupied by other software

Posted on: 2017/9/3 9:59
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: No video stream incorect port number reported in debug
#2
Débutant


Benutzerinformationen
Using the web command as below I'm able to download the m3u8 file and stream the channel via video lan:

http://192.168.1.20/8001/web/stream.m3u?ref=1:0:1:40b:16:2f:6400000:0:0:0:&name=nothing
VLC Option 2 = :audio-track=1



Posted on: 2017/8/28 13:57
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


No video stream incorect port number reported in debug
#1
Débutant


Benutzerinformationen
This is the settings I'm using to connect to my receiver running TitanNit which has an e2webif api
e2 web port=8080
local streamport 8001
username:
password:

24/08/2017 12:46:07 AM 
Zap to TVNZ 1
URL with User
/Password http://:@192.168.1.20:22222/1:0:1:40b:16:2f:6400000:0:0:0:
VLC Option 1 = :http-reconnect=true
Sent HTTP command 
: /web/stream.m3u?ref=1:0:1:40b:16:2f:6400000:0:0:0:&name=nothing
VLC Option 2 
= :audio-track=1
Sent HTTP command 
The remote server returned an error: (404Not Found.
Sent HTTP command : /web/epgnext?bRef=1:7:1:0:0:0:0:0:0:0:FROM BOUQUET "bouquets.english.tv" ORDER BY bouquet


This is the stream the enigma-tv client expects once I connect to my receiver:

http://192.168.1.20:22222/1:0:1:40b:16:2f:6400000:0:0:0:


this is the stream that actually works :


http://192.168.1.20:8001/1:0:1:40b:16:2f:6400000:0:0:0:


if I type the working video lan link into internet explorer I get redirected to another port and shorter url which works in Videolan also:

http://192.168.1.20:22222/1035%2c3080214


I think this is an error in the streamport in enigmatv as it trys to stream on the incorrect port but I'm not really sure how it is ment to work.

would it be worthwile providing a capture with wireshark or a port mirror for the devs to look at ?

 

Attach file:



jpg  setup.jpg (48.15 KB)
44308_59a36619c4260.jpg 800X422 px

Posted on: 2017/8/28 2:39
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]